1.5 升級至 3.X 佈景主題問題



  • 各位好

    小弟最近使用 SP Upgrade 將 1.5 的網站轉移至 3.4 ,轉換核心資料時都正常,但 template 一直轉不過去(ja_purity 1.2),想問版上有人成功移轉嗎?

    過程中修改了

     <install></install>
    ```換成
    

    Juser::authorize() has been removed. Use JUser::authorise() instead.

    JHTML::(‘behavior.mootools’);
    換成
    JHtml::
    (‘behavior.framework’);

    到現在,網頁變成一片空白> <
    
    用 chrome 的檢查,顯示```
    Failed to load resource: the server responded with a status of 500 (Internal Server Error)
    

    真的快崩潰了,如果樣板沒辦法轉換,就需要整個網站重做了。

    麻煩各位了,謝謝!



  • 不僅僅是核心要升級,Template也是

    這一個連結是ja_purity j3版本
    https://www.joomlart.com/joomla/templates/ja-purity-ii



  • 謝謝大大熱心回覆

    你的意思是使用這個 ja_purity 的 j3 版本,有機會維持原設計然後升級 joomla 3 對嗎?
    其中除了調整 css 、新增模組…之外,還有哪些地方可能需要調整呢?

    感激不盡!



  • 你的意思是使用這個 ja_purity 的 j3 版本,有機會維持原設計然後升級 joomla 3 對嗎?

    若舊版的 JA purity與J3版本Layout一樣,而你的模組位置有依照原本的JA的方式是有99%機會維持一樣的

    其中除了調整 css 、新增模組…之外,還有哪些地方可能需要調整呢?

    照理說除非你有自訂修改,才需調整,但實際情況還是得你升級後才知道

    升級前先備份,這是一定要做的事



  • purity沒辦法,以前我有試過了。
    要花時間改,不如重作一個比較快。


登入以回覆

看起來你的連線到 Joomla!台灣討論區 已經遺失,請稍等一下我們嘗試重新連線。