移除某套件後,網站後台登入之後全白



  • 大家好

    小弟目前遇到一個棘手的問題,非常急迫不知該如何解決,只能請教前輩看看…

    我的網站使用joomla 2.5,並且在遠端虛擬主機運作,在安裝了一個叫做slogin的套件後,試用過後把它移除,結果登出網站後,要再從後台登入,當我輸入帳號密碼按下登入後,畫面整個是空白的,如圖所示

    然後按下enter或重新整理網頁,又會回到登入的畫面,使用chrome和IE都一樣

    不知道這樣的情況該如何解決呢?

    希望能請前輩不吝提供解決之道,感激不盡,謝謝大家
    [attachment=3220]blank.jpg[/attachment]



  • 你應該是沒移除乾淨,至少有個外掛影響到。
    如果你安裝的是下面這套:
    http://extensions.joomla.org/extension/slogin

    它裡面有外掛、模組和元件。
    你找一下是不是有System、User、Auth類的外掛,或是直接看一下它的安裝包裡有什麼(.xml檔案之類的)
    或是到外掛裡搜尋slogin或是找製作廠商。

    把外掛或元件先關閉應該就會正常。
    真的不行再回覆吧。



  • 我剛下載那套slogin,裡面有
    元件x1
    模組x1
    函式庫x2 (Library)
    外掛x17 (auth、user、slogin_auth)

    如果你要完全刪乾淨的話,看起來要檢查一下。
    函式庫的名字:
    amcharts
    slogin

    其他你要對照一下,解開壓縮包後會看到裡面有.xml的檔案,裡面有它的名字,拿名字去搜尋你的網站。

    如果你的網站管理區已經掛掉進不去了。
    只能用phpMyAdmin之類的MySQL管理軟體,連到資料庫的extension資料表去手動找和先關閉外掛。

    再試試吧。



  • eddy前輩

    我目前是登入後台完全空白不知道要如何操作

    用phpmyadmin進入資料庫查看,也沒有找到這個套件相關的資料表或是欄位之類的…

    不知道還有甚麼方式可以解救的呢…



  • 爬了一下JOOMLA官方論壇

    有一個類似的案例,他是在更新到3.x版的時候,後台也是空白的,他的解法是將libraries\joomla\html這個資料夾刪除

    於是我先把該資料夾的檔案都備份後,然後照做,結果變成連前台也是空白的了,於是我就趕緊還原該資料夾的檔案,前台就正常了,但後台還是登入後完全空白,不知道這個是不是該從這個資料夾中來找答案呢?



  • 經過一番思考後終於解決了

    eddy前輩所說的的確是套件移除不乾淨所導致

    元凶就是plugins/authentication/slogin這個資料夾有問題,我先把這個資料夾更名,就可以登入後台了,然後再手動徹底的找一次所有slogin的套件相關檔案,把他們都移除,網站就正常了

    感謝前輩解惑,感激不盡



  • @greenmyland:

    爬了一下JOOMLA官方論壇

    有一個類似的案例,他是在更新到3.x版的時候,後台也是空白的,他的解法是將libraries\joomla\html這個資料夾刪除

    於是我先把該資料夾的檔案都備份後,然後照做,結果變成連前台也是空白的了,於是我就趕緊還原該資料夾的檔案,前台就正常了,但後台還是登入後完全空白,不知道這個是不是該從這個資料夾中來找答案呢?

    libraries\joomla\目錄下應該是joomla內建的函式庫,
    一般的外掛除了函式庫類會裝在libraries下,
    但主要工作還是會在其他的程式運作,
    通常只是註冊類別或namespace而已。



  • @greenmyland:

    eddy前輩

    我目前是登入後台完全空白不知道要如何操作

    用phpmyadmin進入資料庫查看,也沒有找到這個套件相關的資料表或是欄位之類的…

    不知道還有甚麼方式可以解救的呢…

    我忘了給你用資料庫關閉外掛的教學連結,不過你現在已經解決了,下面這個有圖解:
    http://coalaweb.com/support/documentation/item/disable-a-joomla-plugin


登入以回覆

看起來你的連線到 Joomla!台灣討論區 已經遺失,請稍等一下我們嘗試重新連線。