【版本問題】Joomla2.5 & 3x 網站移植與相容



  • Dear. 各位版大
    小妹我還是Joomla的初學者,想請問版大們是否有遇過這些問題。

    Q: 公司的B部門 購買了2.5的版型架了網站, 但公司的A部門也跟進想用3.0的系統與版型來架站
    等於是說原本安裝的Joomla 2.5版 需要升級成3.0或者是更高的Joomla系統。

    Q問題一、若是升級想請問是否會影響到B部門(2.5版)呢? 是否可以相容?
    Q問題二、若是B部門也一起升級成Joomla 3x 那是不是原本的2.5版網站就要砍掉重練?
    除非當初購買的版型也能支援相容於3x系統,不然是不能移植的,是這樣的嗎?

    以上是小妹我遇到的問題,不知道各位版大是否也遇過類似的問題
    請求各位版大建議,附圖為小妹購買的版型,感謝您們!! :ohmy:

    【版型資訊】
    Gantry Framework based Template for Joomla! 2.5.x Content Management System
    http://www.gantry-framework.org/



  • 1.不相容
    2.是

    要升級版型是需要參考一些資料,不過要視情況而定,基本上愈複雜的版型愈不好升級,甚至建議不要浪費時間,直接用新的,你的這種是屬於複雜的,因為用到了佈景主題引擎。參考資訊:
    https://docs.joomla.org/J3.x:Converting_A_Previous_Joomla!_Version_Template
    http://stackoverflow.com/questions/16055707/convert-joomla-2-5-template-to-3-0


登入以回覆

看起來你的連線到 Joomla!台灣討論區 已經遺失,請稍等一下我們嘗試重新連線。