MySQL 檔案太大上傳不上去!



  • 我記得以前可以修改 ;
    Maximum allowed size for uploaded files.
    upload_max_filesize = 2M

    可是新安裝的AppSer 在AppSer/www/phpMyAdmin的目錄下 卻找不到phi.ini 檔
    請問我的MySOL data 超過 "載入檔案(最大容量: 81,920KB)"
    如何解決?
    謝謝

    EZCNN



  • 我在另一篇主題有回答 php.ini 的位置,以你在該主題中提到「MySQL 資料庫有 159MB」,
    你是需要修改 php.ini,但是除了檔案上傳上限之外,執行時間、可用的記憶體大小也需要增加。

    到 PHPMyAdmin 的目錄裡找到「config.ini.php」檔案,找到或是自行加入以下兩行:

    $cfg['UploadDir'] = 'ImportSQLFile';  ←上傳資料夾的名稱
    $cfg['SaveDir'] = 'ExportSQLFile';       ←匯出資料夾的名稱
    
    ```然後在 PHPMyAdmin 裡建立「ImportSQLFile」與「ExportSQLFile」兩個資料夾
    作為匯入及匯出 SQL 檔案使用。
    把你的 SQL 檔案放在「ImportSQLFile」資料夾裡,重新讀取 PHPMyAdmin 頁面,
    就會在「匯入」分頁看到新的選項,用這個方法匯入大型資料庫檔案吧。


  • Hi abokuo:

    I have changed the setting as below:

    改過的php.ini
    max_execution_time = 120 ; Maximum execution time of each script, in seconds
    max_input_time = 120 ; Maximum amount of time each script may spend parsing request data
    memory_limit = 256M ; Maximum amount of memory a script may consume (8MB)

    my config.inc.php:
    $cfg[‘UploadDir’] = ‘./NewMySQL’;
    $cfg[‘SaveDir’] = ‘./OldMySQL’;

    My new folders:
    AppSer/www/phpMyAdmin/NewMySQL (put my new database in this folder and rename it as joomla250.sql)
    AppSer/www/phpMyAdmin/OldMySQL (put my original database joomla250.sql in this folder)

    So, what’s the next step?
    I don’t quite understand what you mean.
    “重新讀取 PHPMyAdmin 頁面,
    就會在「匯入」分頁看到新的選項,用這個方法匯入大型資料庫檔案吧。”

    really appreciate

    EZCNN



  • 匯入與匯出的資料夾名稱一定要是「ImportSQLFile」與「ExportSQLFile」。

    [attachment=2721]import_big_sqlfile.png[/attachment]
    import_big_sqlfile.png



  • 我的載入的頁面 看起來和你的不同 找不到你所示範的!

    請問又是哪裡出錯了?

    謝謝
    EZCNN


登入以回覆

看起來你的連線到 Joomla!台灣討論區 已經遺失,請稍等一下我們嘗試重新連線。