新手求助!!網站搬家後首頁無法顯示



  • 網站搬家到新空間後
    首頁都無法顯示
    500錯誤
    但內頁卻可以正常顯示
    後台也可以登入
    不知道是什麼問題 :(



  • Joomla! 版本?怎麼搬移的?原來的網站主機跟新地點名稱?有問過新主機的網管嗎?
    除非人就在你身邊,不然請提供詳細的參考資訊。



  • joomla版本是2.5.9
    我是直接用Akeeba Backup備份
    然後在新的主機安裝
    就變成這樣無法顯示
    www.mit30.com.tw

    原本是在bluehost測試都正常
    我也有把備份下來的檔案
    再重新到bluehost安裝也都是正常顯示

    不知道是我有問題
    還是新主機的哪邊有問題 :(



  • 資料還是不完全,新的主機是哪家也沒說,另外Akeeba備份檔是怎麼下的?用網站?FTP?
    很多狀況都沒說還有之前有沒有裝過保護後台的外掛

    還是擲杯比較快?



  • 對不起
    其實我也不知道新主機是哪家
    只知道聯絡人
    公司之前網頁就放那邊
    好像是對方工作室自己架的主機

    我Akeeba備份檔是從FTP下載的
    /administrator/components/com_akeeba/backup
    這位置抓的ZIP檔
    有試過再回去bluehost安裝ㄧ次是正常的
    想說應該沒問題

    我沒有裝過保護後台的外掛



  • @ljc12300:

    我Akeeba備份檔是從FTP下載的
    /administrator/components/com_akeeba/backup
    這位置抓的ZIP檔
    有試過再回去bluehost安裝ㄧ次是正常的
    想說應該沒問題

    我沒有裝過保護後台的外掛

    如果實際狀況是這樣,沒有其它忘了闡述的問題的話,那就是99.99%主機的問題



  • 新主機的名稱 / 用戶名 / 密碼 / 數據庫是正確的嗎?
    參考[教學]Akeeba Kickstart還原Akeeba備份檔案:
    http://shop.des13.com/extensions/item/189-kickstart



  • 應該都正確的吧
    我後台可以正常登入
    除了首頁之外的其他頁也可以瀏覽
    就主頁Home不能瀏覽



  • Joomla網站換主機,管理區正常,前台網站出現HTTP 錯誤 500

    當Joomla網站搬遷的時候,因為每部主機預設的設定不同,可能會遇到HTTP 錯誤 500 (Internal Server Error)錯誤。

    可以試著調整(加大) php_value memory_limit 的值,例如

    php_value memory_limit 64M
    
    

    可透過.htaccess 中設定,將php的記憶體限制調高。若主機不允許使用.htaccess,建議請網管人員處理一下。

    如果想了解一下可能的問題,也可以把Joomla全站設定中的系統除錯打開(網站上線前記得要關閉) :)

    如果仍無法解決,再留一下訊息,我再幫你確認問題。


  • Global Moderators

    @ljc12300:

    應該都正確的吧
    我後台可以正常登入
    除了首頁之外的其他頁也可以瀏覽
    就主頁Home不能瀏覽

    如果改成預設前台佈景是可以看到首頁,代表佈景有問題。
    如果改成預設前台佈景是不可以看到首頁,代表有模組或外掛衝突。
    可以看apache的錯誤訊息找到一些方向。



  • 我把除錯打開
    錯誤顯示是
    JDatabaseMySQLi::query: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘) GROUP BY comments.itemID’ at line 11 SQL=SELECT content.id AS id, COUNT(comments.itemID) AS count FROM dyeo2_k2_items AS content LEFT JOIN dyeo2_k2_comments AS comments ON comments.itemID = content.id WHERE comments.published AND ( ) GROUP BY comments.itemID ;
    這個怎麼解決呢 :blink:

    喔改成預設的佈景我試了,是正常的
    真的不能用這個佈景了嗎

    感謝大家的建議 :)



  • 9 NSP_GK4_Helper->getDatas() /www/xxx/modules/mod_news_pro_gk4/mod_news_pro_gk4.php:28
    10 NSP_GK4_K2_Source->getComments() /www/xxx/modules/mod_news_pro_gk4/helper.php:297
    11 JDatabase->loadObjectList() /www/xxx/modules/mod_news_pro_gk4/gk_classes/gk.source.k2.php:338

    試著先把mod_news_pro_gk4這個模組關掉看看,可能是因為它的關係。



  • 真的是因為那個原因
    關掉就好了 :)
    所以說那個模組我沒辦法用是嗎
    因為好像用了蠻多地方的 :pinch:

    感謝大家的回覆 謝謝



  • 可能要找到有問題的地方,改一下程式。也可以找一下官方的論壇,看看有沒有相同的問題或是看看有沒有更新的版本 :)


登入以回覆

看起來你的連線到 Joomla!台灣討論區 已經遺失,請稍等一下我們嘗試重新連線。