Appserv2.5.10下的Phpmyadmin版本會出現 PMA_escapeJsString(



  • 我在別地方PO此問題,只想留下紀錄,給日後可能會與我遇到相同問題的使用者
    Appserv2.5.10 裝下去後,當要入phpmyadmin後台時,它就出現這一行
    ’; var opendb_url = '
    Fatal error: Call to undefined function PMA_escapeJsString() in X:\AppServ\www\phpMyAdmin\index.php on line 3
    每次出現時,我得把原本的index.php覆蓋過去,才能進入。這方法只能治標不治本,誰與我遇到同樣問題呢??或者有其他方法可以解決??
    不過似乎沒有人遇到與我一樣的問題,在這幾天搜尋各相關字眼後,終於找到一篇文章,還不知道能不能解決這問題。
    http://www.enet.org.cn/Article/HTML/21356.html

    phpMy Admin PMA_escapeJsString() 跨站脚本漏洞
    受影响系统:
    phpMyAdmin phpMyAdmin < 2.11.9.2

    Appserv2.5.10內的 phpmyadmin版本恰好是2.10.3
    則分別獨立給Phpmyadmin更新到3.3



  • 如果是版本問題,何不更換其他版本試試看呢?


登入以回覆

看起來你的連線到 Joomla!台灣討論區 已經遺失,請稍等一下我們嘗試重新連線。